PDA

View Full Version : mysterious running query/filter


ABC123

Mortie
03-03-2007, 02:26 PM
I have, somwhere, got a query/filter that is running whenver I start a specific form or even try to open it in a design mode.

Any suggestions as to where to turn or how to resovle this problem. It would not be so bad but the tables I am working with have between 900K and 1.5M records.

Stan Mathews
03-03-2007, 04:30 PM
I have, somwhere, got a query/filter that is running whenver I start a specific form or even try to open it in a design mode.

Any suggestions as to where to turn or how to resovle this problem. It would not be so bad but the tables I am working with have between 900K and 1.5M records.

Check the form calculated fields for lookups, filtering, etc.

Al Buchholz
03-03-2007, 05:23 PM
Bob

Using the drop down option on table lookups will do this....

Mortie
03-03-2007, 07:24 PM
Even when I open the default browse for a set it runs the query. That is the ocnfusing part. perhaps it is something in the set design.......will look there......this just started though when I was trying out a new button on a form. This button was uspposed to run a saved query which it did. However, it always found no results even t hough I know the results are in the tables. So I designed a query using an actual data filter rather than variables. It did find my desired data but ever since I have the never ending query. I have since deleted this query and it still happens

Stan Mathews
03-03-2007, 09:38 PM
perhaps it is something in the set design - Do you have any child table filters? That might require some processing each time the set is opened.

Mortie
03-03-2007, 11:19 PM
No filters and no calculated fields in the set.

There are caclulated fields related to the main form but the form worked before.

I am going to try copying the entire application to a temp directory and delete all but 1000 records and see what happens; then the databse will be easier to work with

Mortie
03-04-2007, 11:11 AM
I made copy and was able to open the forms/browse with no delays or activity. I did look at the Query/Index selection list and there were three Temproary Queries of which one was the culprit I do believe. I was able to delete it and tehre is no further problem. However, the other two temporary queries I cannot delete; they continue to return even before I close the selection dialog box.

Any suggestions on how to rid myself of those pesky temporary queries?

michaelc1970
03-26-2007, 06:48 PM
Did you hear any solutions to deleting your pesky temporary queries? I now have 2 temporary queries that I cannot delete.

Bob Arbuthnot
03-26-2007, 07:56 PM
Bob,

Is there a filter on the form itself (open form in design mode -> properties -> Filter/Order)? I've had filters turn up on forms inadvertantly (sp?) in the past.

Also, is there a filtered index on that table?

Bob Arbuthnot

Stan Mathews
03-26-2007, 08:18 PM
Bob,

Is there a filter on the form itself (open form in design mode -> properties -> Filter/Order)? I've had filters turn up on forms inadvertantly (sp?) in the past.

Also, is there a filtered index on that table?

Bob Arbuthnot

inadvertently (corrected sp, because you asked)

(My mother taught English and she beat it into me, figuratively)

Bob Arbuthnot
03-26-2007, 09:11 PM
Hi Stan,

And you know the sad thing is that the message board includes spell check and I found it easier to type 5 characters rather than a couple clicks to find out the correct spelling. Sad commentary on human nature (or at least my nature!).

I'll add grammar and spell checking to your list of talents, though.

Bob

Mortie
03-27-2007, 04:04 PM
the only success I ahve had is to delete the queries, compact the database, delete any $$$$.mpx files I find in the database directory.

When I sjut it down and restart they seem to be gone. The exactreason, I have no idea!

Bob Arbuthnot
03-27-2007, 11:21 PM
Bob,

If you want to find out the problem, post a sample of you database here. I'll bet that you'll have a definitive answer within 1 hour (maybe 2 hours tops!)

Bob A.