Alpha DevCon 2018
Results 1 to 5 of 5

Thread: Message was not sent because of an error - how to use "after Message Sent"?

  1. #1
    Member
    Real Name
    Jaime Ben David
    Join Date
    Jan 2011
    Location
    Karkur, Israel
    Posts
    951

    Default Message was not sent because of an error - how to use "after Message Sent"?

    Started receiving the above error in a UX that uses the "Send EMail" javascript action. Settings were not changed in this app for nearly 3 years, the error started popping this morning.
    My app. server connects to my mail server (exchange) to send, so i built a new relay in exchange ( new receive connector ) which is completely open to my app server's ip.
    From my app server, i can telnet to my mail server and send even without authentication, but it still fails from the app.
    There is a possibility to use an "after Message Sent" property which should be a javascript function, but didn't find any help on how to set this up ( this way i can catch e.errorText ). How can i know why is this failing?

    Many thanks
    Jaime

  2. #2
    Member
    Real Name
    Tim
    Join Date
    Nov 2012
    Posts
    86

    Default Re: Message was not sent because of an error - how to use "after Message Sent"?

    I'm having the same problem. Did you get yours fixed? I see that there was never a response which doesn't really surprise me.

  3. #3
    Member
    Real Name
    Jaime Ben David
    Join Date
    Jan 2011
    Location
    Karkur, Israel
    Posts
    951

    Default Re: Message was not sent because of an error - how to use "after Message Sent"?

    The reason is either wrong username/password but most surely a security issue. In my case, even though the exchange connector was created succesfully, there still were some security issues involved.
    I don't remember exactly, but you need to check
    1) NAT in your server's network router
    2) exchange connector open for you app's server it --> security --> check "External security (IPSec)"
    3) Check no antispam software in the exchange server blocks your app

  4. #4
    Member
    Real Name
    Tim
    Join Date
    Nov 2012
    Posts
    86

    Default Re: Message was not sent because of an error - how to use "after Message Sent"?

    I'll check it out. thank you!

  5. #5
    Member
    Real Name
    Jaime Ben David
    Join Date
    Jan 2011
    Location
    Karkur, Israel
    Posts
    951

    Default Re: Message was not sent because of an error - how to use "after Message Sent"?

    in 2) there is a typo should be "exchange connector open for your app's server IP" ...

Similar Threads

  1. "Send Email Message" Using Action Script in "afterDialogValidate"
    By dalebra in forum Application Server Version 11 - Web/Browser Applications
    Replies: 3
    Last Post: 12-14-2012, 09:14 AM
  2. SQL error message: expecting RPAREN, found "LEFT"
    By lfagerman in forum Application Server Version 10 - Web/Browser Applications
    Replies: 7
    Last Post: 10-07-2010, 12:24 PM
  3. A4V6-"No file handles left"Error message
    By RALPH WHALEY in forum Alpha Four Version 6 and Prior
    Replies: 6
    Last Post: 11-11-2009, 05:35 AM
  4. Error message: "Can't add tag to compound index"
    By thmontgomery in forum Alpha Five Version 8
    Replies: 2
    Last Post: 03-30-2008, 11:58 PM
  5. Error message - "Could not re-build Addin-library.aex"
    By brett s in forum Alpha Five Version 8
    Replies: 2
    Last Post: 02-19-2007, 01:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •