Get a Jumpstart with our Sample Apps
Results 1 to 28 of 28

Thread: Phonegap Build error

  1. #1
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Phonegap Build error

    HI everyone.

    Today i try to update a new app to phonegap but i got fail for IOS and Android.What makes me more puzzled i dont have this issues before.Previously I`m using cli-6.3.0 . Since it return me error and did not build the app i upgrade it to 6.5.0 but it still fail..Can anyone help me with this. I`ve even try to change the plugin version but still return error. I need to fix this ASAP.

    Below is my config.xml.


    <?xml version='1.0' encoding='utf-8'?>
    <widget id="com.poi.poi2u" version="0.0.1" versionCode="1" xmlns="http://www.w3.org/ns/widgets" xmlns:gap="http://phonegap.com/ns/1.0">
    <name>POI2U</name>
    <description>
    For POI purpose
    </description>
    <author email="" href="">
    POGT 2016
    </author>
    <feature name="http://api.phonegap.com/1.0/device" />
    <preference name="permissions" value="" />
    <preference name="orientation" value="default" />
    <preference name="target-device" value="universal" />
    <preference name="fullscreen" value="false" />
    <preference name="webviewbounce" value="true" />
    <preference name="prerendered-icon" value="true" />
    <preference name="stay-in-webview" value="false" />
    <preference name="ios-statusbarstyle" value="default" />
    <preference name="detect-data-types" value="true" />
    <preference name="exit-on-suspend" value="false" />
    <preference name="show-splash-screen-spinner" value="true" />
    <preference name="auto-hide-splash-screen" value="true" />
    <preference name="disable-cursor" value="false" />
    <preference name="android-minSdkVersion" value="14" />
    <preference name="android-installLocation" value="internalOnly" />
    <preference name="phonegap-version" value="cli-6.5.0" />
    <preference name="FadeSplashScreen" value="true" />
    <preference name="FadeSplashScreenDuration" value="2" />
    <preference name="EnableViewportScale" value="false" />
    <preference name="MediaPlaybackRequiresUserAction" value="true" />
    <preference name="AllowInlineMediaPlayback" value="false" />
    <preference name="TopActivityIndicator" value="gray" />
    <preference name="BackupWebStorage" value="none" />
    <preference name="iosPersistentFileLocation" value="Library" />
    <preference name="KeyboardDisplayRequiresUserAction" value="false" />
    <preference name="SurpressesIncrementalRendering" value="true" />
    <preference name="android-maxSdkVersion" value="" />
    <preference name="android-targetSdkVersion" value="" />
    <preference name="KeepRunning" value="true" />
    <preference name="splash-screen-duration" value="5000" />
    <preference name="ErrorUrl" value="error.html" />
    <preference name="LoadingDialog" value="Please wait, the app is loading." />
    <preference name="LoadingPageDialog" value="Please wait, the data is loading." />
    <preference name="LoadUrlTimeoutValue" value="20000" />
    <preference name="AndroidPersistentFileLocation" value="Internal" />
    <preference name="android-build-tool" value="gradle" />
    <icon src="icon.png" />
    <splash src="splash.png" />
    <splash platform="ios" height="1136" src="res/screen/ios/screen-iphone-portrait-568h-2x.png" width="640" />
    <icon platform="android" qualifier="ldpi" src="res/icon/android/icon-36-ldpi.png" />
    <icon platform="android" qualifier="mdpi" src="res/icon/android/icon-48-mdpi.png" />
    <icon platform="android" qualifier="hdpi" src="res/icon/android/icon-72-hdpi.png" />
    <icon platform="android" qualifier="xhdpi" src="res/icon/android/icon-96-xhdpi.png" />
    <icon platform="android" qualifier="xxhdpi" src="res/icon/android/icon-144-xxhdpi.png" />
    <icon platform="ios" src="res/icon/ios/icon-small.png" width="29" height="29" />
    <icon platform="ios" src="res/icon/ios/icon-40.png" width="40" height="40" />
    <icon platform="ios" src="res/icon/ios/icon-50.png" width="50" height="50" />
    <icon platform="ios" src="res/icon/ios/icon-57.png" width="57" height="57" />
    <icon platform="ios" src="res/icon/ios/icon-60.png" width="60" height="60" />
    <icon platform="ios" src="res/icon/ios/icon-72.png" width="72" height="72" />
    <icon platform="ios" src="res/icon/ios/icon-76.png" width="76" height="76" />
    <icon platform="ios" src="res/icon/ios/icon-small-2x.png" width="58" height="58" />
    <icon platform="ios" src="res/icon/ios/icon-40-2x.png" width="80" height="80" />
    <icon platform="ios" src="res/icon/ios/icon-50-2x.png" width="100" height="100" />
    <icon platform="ios" src="res/icon/ios/icon-57-2x.png" width="114" height="114" />
    <icon platform="ios" src="res/icon/ios/icon-60-2x.png" width="120" height="120" />
    <icon platform="ios" src="res/icon/ios/icon-72-2x.png" width="144" height="144" />
    <icon platform="ios" src="res/icon/ios/icon-76-2x.png" width="152" height="152" />
    <icon platform="ios" src="res/icon/ios/icon-60-3x.png" width="180" height="180" />
    <!-- Windows Phone 8 -->
    <icon platform="winphone" src="res/icon/windows-phone/icon-48.png" />
    <icon platform="winphone" src="res/icon/windows-phone/icon-62-tile.png" role="background" />
    <!-- Windows Phone 8.1+ -->
    <icon platform="winphone" src="res/icon/windows-phone/square44x44logo.scale-100.png" width="44" height="44"/>
    <icon platform="winphone" src="res/icon/windows-phone/square44x44logo.scale-240.png" width="106" height="106"/>
    <icon platform="winphone" src="res/icon/windows-phone/square150x150logo.scale-100.png" width="150" height="150"/>
    <icon platform="winphone" src="res/icon/windows-phone/square150x150logo.scale-240.png" width="360" height="360"/>
    <icon platform="winphone" src="res/icon/windows-phone/square71x71logo.scale-100.png" width="71" height="71"/>
    <icon platform="winphone" src="res/icon/windows-phone/square71x71logo.scale-240.png" width="170" height="170"/>
    <!-- Launch images / splash screens -->
    <splash platform="android" qualifier="port-ldpi" src="res/screen/android/screen-ldpi-portrait.png" />
    <splash platform="android" qualifier="port-mdpi" src="res/screen/android/screen-mdpi-portrait.png" />
    <splash platform="android" qualifier="port-hdpi" src="res/screen/android/screen-hdpi-portrait.png" />
    <splash platform="android" qualifier="port-xhdpi" src="res/screen/android/screen-xhdpi-portrait.png" />
    <splash platform="android" qualifier="port-xhdpi" src="res/screen/android/screen-xhdpi-n7-portrait.png" />
    <splash platform="android" qualifier="port-xxhdpi" src="res/screen/android/screen-xxhdpi-portrait.png" />
    <splash platform="android" qualifier="port-xxhdpi" src="res/screen/android/screen-xxhdpi-n7-portrait.png" />
    <splash platform="android" qualifier="land-xxhdpi" src="res/screen/android/screen-xxhdpi-n7-landscape.png" width="1920" height="1200" />
    <splash platform="android" qualifier="land-xxhdpi" src="res/screen/android/screen-xxhdpi-landscape.png" width="1920" height="1080" />
    <splash platform="android" qualifier="land-xhdpi" src="res/screen/android/screen-xhdpi-n7-landscape.png" width="1280" height="800" />
    <splash platform="android" qualifier="land-xhdpi" src="res/screen/android/screen-xhdpi-landscape.png" width="1280" height="720" />
    <splash platform="android" qualifier="land-hdpi" src="res/screen/android/screen-hdpi-landscape.png" width ="800" height="480" />
    <splash platform="android" qualifier="land-mdpi" src="res/screen/android/screen-mdpi-landscape.png" width="480" height="320" />
    <splash platform="android" qualifier="land-ldpi" src="res/screen/android/screen-ldpi-landscape.png" width="320" height="200" />
    <!-- iPhone and iPod Touch -->
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait.png" width="320" height="480" />
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-2x.png" width="640" height="960" />
    <!-- iPhone 5 and iPod Touch (5th generation) -->
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-568h-2x.png" width="640" height="1136" />
    <!-- iPhone 6 -->
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-667h-2x.png" width="750" height="1334" />
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-736h-3x.png" width="1242" height="2208" />
    <!-- iPad -->
    <splash platform="ios" src="res/screen/ios/screen-ipad-portrait.png" width="768" height="1024" />
    <splash platform="ios" src="res/screen/ios/screen-ipad-landscape.png" width="1024" height="768" />
    <!-- Retina iPad -->
    <splash platform="ios" src="res/screen/ios/screen-ipad-portrait-2x.png" width="1536" height="2048" />
    <splash platform="ios" src="res/screen/ios/screen-ipad-landscape-2x.png" width="2048" height="1536" />
    <!-- Windows 8 -->
    <splash platform="winphone" src="res/screen/windows-phone/screen-portrait.jpg" />
    <!-- Windows 8.1 -->
    <splash platform="winphone" src ="res/screen/windows-phone/screen.scale-240.png" />
    <access origin="*" />
    <allow-navigation href="http://*/*" />
    <allow-navigation href="https://*/*" />
    <allow-navigation href="data:*" />
    <allow-intent href="http://*/*" />
    <allow-intent href="https://*/*" />
    <platform name="ios" />
    <platform name="android" />
    <feature name="http://api.phonegap.com/1.0/file" />
    <feature name="http://api.phonegap.com/1.0/network" />
    <plugin name="cordova-plugin-console" source="npm" />
    <plugin name="cordova-plugin-device" source="npm" />
    <plugin name="cordova-plugin-device-motion" source="npm" />
    <plugin name="cordova-plugin-device-orientation" source="npm" />
    <plugin name="cordova-plugin-file" source="npm" />
    <plugin name="cordova-plugin-network-information" source="npm" />
    <plugin name="cordova-plugin-splashscreen" source="npm" />

    <plugin name="cordova-plugin-spinnerdialog" source="npm" />
    <plugin name="cordova-plugin-whitelist" source="npm" />

    <plugin name="ionic-plugin-keyboard" source="npm" />
    <plugin name="com.peerio.cordova.plugin.privacyscreen" spec="1.0.2" source="npm" />
    <plugin name="cordova-plugin-blurred-snapshot" spec="0.1.3" source="npm" />
    <plugin name="cordova-privacy-screen-plugin-mra" spec="0.3.1" source="npm" />
    <plugin spec="https://github.com/lifeofcoding/cordova-blur-app-privacy-screen.git" source="npm" />
    <plugin spec="https://github.com/ti8m/DocumentHandler.git" source="git" />



    <plugin name="cordova-plugin-dialogs" source="npm" />
    <plugin name="cordova-plugin-file-transfer" source="npm" version="1.5.1" />
    <plugin name="cordova-plugin-datepicker" source="npm" />
    <plugin name="cordova-plugin-file-opener2-base64" source="npm" />
    <plugin name="cordova-plugin-image-picker" source="npm" />
    <plugin name="cordova-plugin-native-transitions" source="npm" />
    <plugin name="de.appplant.cordova.plugin.printer" source="npm" />
    <plugin name="pushwoosh-pgb-plugin" source="npm" />

    <gap:config-file platform="ios" parent="UIBackgroundModes" overwrite="true">
    <array>
    <string>location</string>
    </array>
    </gap:config-file>


    <gap:config-file platform="ios" parent="NSLocationAlwaysUsageDescription">
    <string>This app uses location services for use with push notifications.</string>
    </gap:config-file>

    <plugin name="cordova-plugin-blurred-snapshot" source="npm" />
    <plugin name="cordova-privacy-screen-plugin-mra" source="npm" />
    <plugin name="com.peerio.cordova.plugin.privacyscreen" source="npm" />
    <plugin name="cordova-plugin-statusbar" source="npm" />
    <plugin name="cordova-plugin-x-toast" source="npm" />
    <plugin name="phonegap-plugin-push" source="npm" />
    <plugin spec="https://github.com/ti8m/DocumentHandler" source="git" />

    <plugin name="cordova-open" source="npm" />
    <plugin name="cordova-plugin-inappbrowser" source="npm" />
    </widget>

  2. #2
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Quote Originally Posted by fatiha@pacific-orient.com View Post
    HI everyone.

    Today i try to update a new app to phonegap but i got fail for IOS and Android.What makes me more puzzled i dont have this issues before.Previously I`m using cli-6.3.0 . Since it return me error and did not build the app i upgrade it to 6.5.0 but it still fail..Can anyone help me with this. I`ve even try to change the plugin version but still return error. I need to fix this ASAP.

    Below is my config.xml.


    <?xml version='1.0' encoding='utf-8'?>
    <widget id="com.poi.poi2u" version="0.0.1" versionCode="1" xmlns="http://www.w3.org/ns/widgets" xmlns:gap="http://phonegap.com/ns/1.0">
    <name>POI2U</name>
    <description>
    For POI purpose
    </description>
    <author email="" href="">
    POGT 2016
    </author>
    <feature name="http://api.phonegap.com/1.0/device" />
    <preference name="permissions" value="" />
    <preference name="orientation" value="default" />
    <preference name="target-device" value="universal" />
    <preference name="fullscreen" value="false" />
    <preference name="webviewbounce" value="true" />
    <preference name="prerendered-icon" value="true" />
    <preference name="stay-in-webview" value="false" />
    <preference name="ios-statusbarstyle" value="default" />
    <preference name="detect-data-types" value="true" />
    <preference name="exit-on-suspend" value="false" />
    <preference name="show-splash-screen-spinner" value="true" />
    <preference name="auto-hide-splash-screen" value="true" />
    <preference name="disable-cursor" value="false" />
    <preference name="android-minSdkVersion" value="14" />
    <preference name="android-installLocation" value="internalOnly" />
    <preference name="phonegap-version" value="cli-6.5.0" />
    <preference name="FadeSplashScreen" value="true" />
    <preference name="FadeSplashScreenDuration" value="2" />
    <preference name="EnableViewportScale" value="false" />
    <preference name="MediaPlaybackRequiresUserAction" value="true" />
    <preference name="AllowInlineMediaPlayback" value="false" />
    <preference name="TopActivityIndicator" value="gray" />
    <preference name="BackupWebStorage" value="none" />
    <preference name="iosPersistentFileLocation" value="Library" />
    <preference name="KeyboardDisplayRequiresUserAction" value="false" />
    <preference name="SurpressesIncrementalRendering" value="true" />
    <preference name="android-maxSdkVersion" value="" />
    <preference name="android-targetSdkVersion" value="" />
    <preference name="KeepRunning" value="true" />
    <preference name="splash-screen-duration" value="5000" />
    <preference name="ErrorUrl" value="error.html" />
    <preference name="LoadingDialog" value="Please wait, the app is loading." />
    <preference name="LoadingPageDialog" value="Please wait, the data is loading." />
    <preference name="LoadUrlTimeoutValue" value="20000" />
    <preference name="AndroidPersistentFileLocation" value="Internal" />
    <preference name="android-build-tool" value="gradle" />
    <icon src="icon.png" />
    <splash src="splash.png" />
    <splash platform="ios" height="1136" src="res/screen/ios/screen-iphone-portrait-568h-2x.png" width="640" />
    <icon platform="android" qualifier="ldpi" src="res/icon/android/icon-36-ldpi.png" />
    <icon platform="android" qualifier="mdpi" src="res/icon/android/icon-48-mdpi.png" />
    <icon platform="android" qualifier="hdpi" src="res/icon/android/icon-72-hdpi.png" />
    <icon platform="android" qualifier="xhdpi" src="res/icon/android/icon-96-xhdpi.png" />
    <icon platform="android" qualifier="xxhdpi" src="res/icon/android/icon-144-xxhdpi.png" />
    <icon platform="ios" src="res/icon/ios/icon-small.png" width="29" height="29" />
    <icon platform="ios" src="res/icon/ios/icon-40.png" width="40" height="40" />
    <icon platform="ios" src="res/icon/ios/icon-50.png" width="50" height="50" />
    <icon platform="ios" src="res/icon/ios/icon-57.png" width="57" height="57" />
    <icon platform="ios" src="res/icon/ios/icon-60.png" width="60" height="60" />
    <icon platform="ios" src="res/icon/ios/icon-72.png" width="72" height="72" />
    <icon platform="ios" src="res/icon/ios/icon-76.png" width="76" height="76" />
    <icon platform="ios" src="res/icon/ios/icon-small-2x.png" width="58" height="58" />
    <icon platform="ios" src="res/icon/ios/icon-40-2x.png" width="80" height="80" />
    <icon platform="ios" src="res/icon/ios/icon-50-2x.png" width="100" height="100" />
    <icon platform="ios" src="res/icon/ios/icon-57-2x.png" width="114" height="114" />
    <icon platform="ios" src="res/icon/ios/icon-60-2x.png" width="120" height="120" />
    <icon platform="ios" src="res/icon/ios/icon-72-2x.png" width="144" height="144" />
    <icon platform="ios" src="res/icon/ios/icon-76-2x.png" width="152" height="152" />
    <icon platform="ios" src="res/icon/ios/icon-60-3x.png" width="180" height="180" />
    <!-- Windows Phone 8 -->
    <icon platform="winphone" src="res/icon/windows-phone/icon-48.png" />
    <icon platform="winphone" src="res/icon/windows-phone/icon-62-tile.png" role="background" />
    <!-- Windows Phone 8.1+ -->
    <icon platform="winphone" src="res/icon/windows-phone/square44x44logo.scale-100.png" width="44" height="44"/>
    <icon platform="winphone" src="res/icon/windows-phone/square44x44logo.scale-240.png" width="106" height="106"/>
    <icon platform="winphone" src="res/icon/windows-phone/square150x150logo.scale-100.png" width="150" height="150"/>
    <icon platform="winphone" src="res/icon/windows-phone/square150x150logo.scale-240.png" width="360" height="360"/>
    <icon platform="winphone" src="res/icon/windows-phone/square71x71logo.scale-100.png" width="71" height="71"/>
    <icon platform="winphone" src="res/icon/windows-phone/square71x71logo.scale-240.png" width="170" height="170"/>
    <!-- Launch images / splash screens -->
    <splash platform="android" qualifier="port-ldpi" src="res/screen/android/screen-ldpi-portrait.png" />
    <splash platform="android" qualifier="port-mdpi" src="res/screen/android/screen-mdpi-portrait.png" />
    <splash platform="android" qualifier="port-hdpi" src="res/screen/android/screen-hdpi-portrait.png" />
    <splash platform="android" qualifier="port-xhdpi" src="res/screen/android/screen-xhdpi-portrait.png" />
    <splash platform="android" qualifier="port-xhdpi" src="res/screen/android/screen-xhdpi-n7-portrait.png" />
    <splash platform="android" qualifier="port-xxhdpi" src="res/screen/android/screen-xxhdpi-portrait.png" />
    <splash platform="android" qualifier="port-xxhdpi" src="res/screen/android/screen-xxhdpi-n7-portrait.png" />
    <splash platform="android" qualifier="land-xxhdpi" src="res/screen/android/screen-xxhdpi-n7-landscape.png" width="1920" height="1200" />
    <splash platform="android" qualifier="land-xxhdpi" src="res/screen/android/screen-xxhdpi-landscape.png" width="1920" height="1080" />
    <splash platform="android" qualifier="land-xhdpi" src="res/screen/android/screen-xhdpi-n7-landscape.png" width="1280" height="800" />
    <splash platform="android" qualifier="land-xhdpi" src="res/screen/android/screen-xhdpi-landscape.png" width="1280" height="720" />
    <splash platform="android" qualifier="land-hdpi" src="res/screen/android/screen-hdpi-landscape.png" width ="800" height="480" />
    <splash platform="android" qualifier="land-mdpi" src="res/screen/android/screen-mdpi-landscape.png" width="480" height="320" />
    <splash platform="android" qualifier="land-ldpi" src="res/screen/android/screen-ldpi-landscape.png" width="320" height="200" />
    <!-- iPhone and iPod Touch -->
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait.png" width="320" height="480" />
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-2x.png" width="640" height="960" />
    <!-- iPhone 5 and iPod Touch (5th generation) -->
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-568h-2x.png" width="640" height="1136" />
    <!-- iPhone 6 -->
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-667h-2x.png" width="750" height="1334" />
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-736h-3x.png" width="1242" height="2208" />
    <!-- iPad -->
    <splash platform="ios" src="res/screen/ios/screen-ipad-portrait.png" width="768" height="1024" />
    <splash platform="ios" src="res/screen/ios/screen-ipad-landscape.png" width="1024" height="768" />
    <!-- Retina iPad -->
    <splash platform="ios" src="res/screen/ios/screen-ipad-portrait-2x.png" width="1536" height="2048" />
    <splash platform="ios" src="res/screen/ios/screen-ipad-landscape-2x.png" width="2048" height="1536" />
    <!-- Windows 8 -->
    <splash platform="winphone" src="res/screen/windows-phone/screen-portrait.jpg" />
    <!-- Windows 8.1 -->
    <splash platform="winphone" src ="res/screen/windows-phone/screen.scale-240.png" />
    <access origin="*" />
    <allow-navigation href="http://*/*" />
    <allow-navigation href="https://*/*" />
    <allow-navigation href="data:*" />
    <allow-intent href="http://*/*" />
    <allow-intent href="https://*/*" />
    <platform name="ios" />
    <platform name="android" />
    <feature name="http://api.phonegap.com/1.0/file" />
    <feature name="http://api.phonegap.com/1.0/network" />
    <plugin name="cordova-plugin-console" source="npm" />
    <plugin name="cordova-plugin-device" source="npm" />
    <plugin name="cordova-plugin-device-motion" source="npm" />
    <plugin name="cordova-plugin-device-orientation" source="npm" />
    <plugin name="cordova-plugin-file" source="npm" />
    <plugin name="cordova-plugin-network-information" source="npm" />
    <plugin name="cordova-plugin-splashscreen" source="npm" />

    <plugin name="cordova-plugin-spinnerdialog" source="npm" />
    <plugin name="cordova-plugin-whitelist" source="npm" />

    <plugin name="ionic-plugin-keyboard" source="npm" />
    <plugin name="com.peerio.cordova.plugin.privacyscreen" spec="1.0.2" source="npm" />
    <plugin name="cordova-plugin-blurred-snapshot" spec="0.1.3" source="npm" />
    <plugin name="cordova-privacy-screen-plugin-mra" spec="0.3.1" source="npm" />
    <plugin spec="https://github.com/lifeofcoding/cordova-blur-app-privacy-screen.git" source="npm" />
    <plugin spec="https://github.com/ti8m/DocumentHandler.git" source="git" />



    <plugin name="cordova-plugin-dialogs" source="npm" />
    <plugin name="cordova-plugin-file-transfer" source="npm" version="1.5.1" />
    <plugin name="cordova-plugin-datepicker" source="npm" />
    <plugin name="cordova-plugin-file-opener2-base64" source="npm" />
    <plugin name="cordova-plugin-image-picker" source="npm" />
    <plugin name="cordova-plugin-native-transitions" source="npm" />
    <plugin name="de.appplant.cordova.plugin.printer" source="npm" />
    <plugin name="pushwoosh-pgb-plugin" source="npm" />

    <gap:config-file platform="ios" parent="UIBackgroundModes" overwrite="true">
    <array>
    <string>location</string>
    </array>
    </gap:config-file>


    <gap:config-file platform="ios" parent="NSLocationAlwaysUsageDescription">
    <string>This app uses location services for use with push notifications.</string>
    </gap:config-file>

    <plugin name="cordova-plugin-blurred-snapshot" source="npm" />
    <plugin name="cordova-privacy-screen-plugin-mra" source="npm" />
    <plugin name="com.peerio.cordova.plugin.privacyscreen" source="npm" />
    <plugin name="cordova-plugin-statusbar" source="npm" />
    <plugin name="cordova-plugin-x-toast" source="npm" />
    <plugin name="phonegap-plugin-push" source="npm" />
    <plugin spec="https://github.com/ti8m/DocumentHandler" source="git" />

    <plugin name="cordova-open" source="npm" />
    <plugin name="cordova-plugin-inappbrowser" source="npm" />
    </widget>
    and this is the log file for android




    Build Date: 2017-11-13 07:59:36 +0000
    --------------------------------------------------------------------------------
    PLUGIN OUTPUT
    --------------------------------------------------------------------------------
    Fetching plugin "cordova-plugin-console" via npm
    Installing "cordova-plugin-console" at "1.1.0" for android
    Fetching plugin "cordova-plugin-device" via npm
    Installing "cordova-plugin-device" at "1.1.7" for android
    Fetching plugin "cordova-plugin-device-motion" via npm
    Installing "cordova-plugin-device-motion" at "2.0.0" for android

    [DEPRECATED] - cordova-plugin-device-motion
    With the W3C Device Motion and Orientation API now being supported on iOS, Android and Windows devices, this plugin is not needed any more. Read more about the API at https://www.w3.org/TR/2016/CR-orient...vent-20160818/
    Fetching plugin "cordova-plugin-device-orientation" via npm
    Installing "cordova-plugin-device-orientation" at "2.0.0" for android

    [DEPRECATED] - cordova-plugin-device-orientation
    With the W3C Device Motion and Orientation API now being supported on iOS, Android and Windows devices, this plugin is not needed any more. Read more about the API at https://www.w3.org/TR/2016/CR-orient...vent-20160818/
    Fetching plugin "cordova-plugin-file" via npm
    Installing "cordova-plugin-file" at "5.0.0" for android
    Plugin doesn't support this project's cordova-android version. cordova-android: 6.1.2, failed version requirement: >=6.3.0
    Skipping 'cordova-plugin-file' for android
    Fetching plugin "cordova-plugin-network-information" via npm
    Installing "cordova-plugin-network-information" at "1.3.4" for android
    Fetching plugin "cordova-plugin-splashscreen" via npm
    Installing "cordova-plugin-splashscreen" at "4.1.0" for android
    Fetching plugin "cordova-plugin-spinnerdialog" via npm
    Installing "cordova-plugin-spinnerdialog" at "1.3.2" for android
    Fetching plugin "cordova-plugin-whitelist" via npm
    Installing "cordova-plugin-whitelist" at "1.3.3" for android

    This plugin is only applicable for versions of cordova-android greater than 4.0. If you have a previous platform version, you do *not* need this plugin since the whitelist will be built in.
    Fetching plugin "ionic-plugin-keyboard" via npm
    Installing "ionic-plugin-keyboard" at "2.2.1" for android
    Fetching plugin "com.peerio.cordova.plugin.privacyscreen@1.0.2" via npm
    Installing "com.peerio.cordova.plugin.privacyscreen" at "1.0.0" for android
    Fetching plugin "cordova-plugin-blurred-snapshot@0.1.3" via npm
    Installing "cordova-plugin-blurred-snapshot" at "0.1.3" for android
    Fetching plugin "cordova-privacy-screen-plugin-mra@0.3.1" via npm
    Installing "cordova-privacy-screen-plugin-mra" at "0.3.1" for android
    Fetching plugin "https://github.com/lifeofcoding/cordova-blur-app-privacy-screen.git" via git clone
    Using shallow clone
    Repository "https://github.com/lifeofcoding/cordova-blur-app-privacy-screen.git" checked out to git ref "master" at "e9a6974".
    Installing "cordova-blur-app-privacy-screen" at "0.0.1" for android
    Fetching plugin "https://github.com/ti8m/DocumentHandler.git" via git clone
    Using shallow clone
    Repository "https://github.com/ti8m/DocumentHandler.git" checked out to git ref "master" at "f501154".
    Installing "ch.ti8m.documenthandler" at "0.2.2" for android
    Fetching plugin "cordova-plugin-dialogs" via npm
    Installing "cordova-plugin-dialogs" at "1.3.4" for android
    "plugman install --platform android --project /project --plugin cordova-plugin-file-transfer@1.5.1": Fetching plugin "cordova-plugin-file-transfer@1.5.1" via npm
    Installing "cordova-plugin-file-transfer" at "1.5.1" for android
    Failed to install 'cordova-plugin-file-transfer': CordovaError: Version of installed plugin: "cordova-plugin-file@5.0.0" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency.
    at /.npm/lib/node_modules/pgb-plugman/node_modules/pgb-cordova-lib/src/plugman/install.js:581:33
    at _fulfilled (/.npm/lib/node_modules/pgb-plugman/node_modules/q/q.js:787:54)
    at self.promiseDispatch.done (/.npm/lib/node_modules/pgb-plugman/node_modules/q/q.js:816:30)
    at Promise.promise.promiseDispatch (/.npm/lib/node_modules/pgb-plugman/node_modules/q/q.js:749:13)
    at /.npm/lib/node_modules/pgb-plugman/node_modules/q/q.js:509:49
    at flush (/.npm/lib/node_modules/pgb-plugman/node_modules/q/q.js:108:17)
    at _combinedTickCallback (internal/process/next_tick.js:67:7)
    at process._tickCallback (internal/process/next_tick.js:98:9)
    Version of installed plugin: "cordova-plugin-file@5.0.0" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency.

  3. #3
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Quote Originally Posted by fatiha@pacific-orient.com View Post
    HI everyone.

    Today i try to update a new app to phonegap but i got fail for IOS and Android.What makes me more puzzled i dont have this issues before.Previously I`m using cli-6.3.0 . Since it return me error and did not build the app i upgrade it to 6.5.0 but it still fail..Can anyone help me with this. I`ve even try to change the plugin version but still return error. I need to fix this ASAP.

    Below is my config.xml.


    <?xml version='1.0' encoding='utf-8'?>
    <widget id="com.poi.poi2u" version="0.0.1" versionCode="1" xmlns="http://www.w3.org/ns/widgets" xmlns:gap="http://phonegap.com/ns/1.0">
    <name>POI2U</name>
    <description>
    For POI purpose
    </description>
    <author email="" href="">
    POGT 2016
    </author>
    <feature name="http://api.phonegap.com/1.0/device" />
    <preference name="permissions" value="" />
    <preference name="orientation" value="default" />
    <preference name="target-device" value="universal" />
    <preference name="fullscreen" value="false" />
    <preference name="webviewbounce" value="true" />
    <preference name="prerendered-icon" value="true" />
    <preference name="stay-in-webview" value="false" />
    <preference name="ios-statusbarstyle" value="default" />
    <preference name="detect-data-types" value="true" />
    <preference name="exit-on-suspend" value="false" />
    <preference name="show-splash-screen-spinner" value="true" />
    <preference name="auto-hide-splash-screen" value="true" />
    <preference name="disable-cursor" value="false" />
    <preference name="android-minSdkVersion" value="14" />
    <preference name="android-installLocation" value="internalOnly" />
    <preference name="phonegap-version" value="cli-6.5.0" />
    <preference name="FadeSplashScreen" value="true" />
    <preference name="FadeSplashScreenDuration" value="2" />
    <preference name="EnableViewportScale" value="false" />
    <preference name="MediaPlaybackRequiresUserAction" value="true" />
    <preference name="AllowInlineMediaPlayback" value="false" />
    <preference name="TopActivityIndicator" value="gray" />
    <preference name="BackupWebStorage" value="none" />
    <preference name="iosPersistentFileLocation" value="Library" />
    <preference name="KeyboardDisplayRequiresUserAction" value="false" />
    <preference name="SurpressesIncrementalRendering" value="true" />
    <preference name="android-maxSdkVersion" value="" />
    <preference name="android-targetSdkVersion" value="" />
    <preference name="KeepRunning" value="true" />
    <preference name="splash-screen-duration" value="5000" />
    <preference name="ErrorUrl" value="error.html" />
    <preference name="LoadingDialog" value="Please wait, the app is loading." />
    <preference name="LoadingPageDialog" value="Please wait, the data is loading." />
    <preference name="LoadUrlTimeoutValue" value="20000" />
    <preference name="AndroidPersistentFileLocation" value="Internal" />
    <preference name="android-build-tool" value="gradle" />
    <icon src="icon.png" />
    <splash src="splash.png" />
    <splash platform="ios" height="1136" src="res/screen/ios/screen-iphone-portrait-568h-2x.png" width="640" />
    <icon platform="android" qualifier="ldpi" src="res/icon/android/icon-36-ldpi.png" />
    <icon platform="android" qualifier="mdpi" src="res/icon/android/icon-48-mdpi.png" />
    <icon platform="android" qualifier="hdpi" src="res/icon/android/icon-72-hdpi.png" />
    <icon platform="android" qualifier="xhdpi" src="res/icon/android/icon-96-xhdpi.png" />
    <icon platform="android" qualifier="xxhdpi" src="res/icon/android/icon-144-xxhdpi.png" />
    <icon platform="ios" src="res/icon/ios/icon-small.png" width="29" height="29" />
    <icon platform="ios" src="res/icon/ios/icon-40.png" width="40" height="40" />
    <icon platform="ios" src="res/icon/ios/icon-50.png" width="50" height="50" />
    <icon platform="ios" src="res/icon/ios/icon-57.png" width="57" height="57" />
    <icon platform="ios" src="res/icon/ios/icon-60.png" width="60" height="60" />
    <icon platform="ios" src="res/icon/ios/icon-72.png" width="72" height="72" />
    <icon platform="ios" src="res/icon/ios/icon-76.png" width="76" height="76" />
    <icon platform="ios" src="res/icon/ios/icon-small-2x.png" width="58" height="58" />
    <icon platform="ios" src="res/icon/ios/icon-40-2x.png" width="80" height="80" />
    <icon platform="ios" src="res/icon/ios/icon-50-2x.png" width="100" height="100" />
    <icon platform="ios" src="res/icon/ios/icon-57-2x.png" width="114" height="114" />
    <icon platform="ios" src="res/icon/ios/icon-60-2x.png" width="120" height="120" />
    <icon platform="ios" src="res/icon/ios/icon-72-2x.png" width="144" height="144" />
    <icon platform="ios" src="res/icon/ios/icon-76-2x.png" width="152" height="152" />
    <icon platform="ios" src="res/icon/ios/icon-60-3x.png" width="180" height="180" />
    <!-- Windows Phone 8 -->
    <icon platform="winphone" src="res/icon/windows-phone/icon-48.png" />
    <icon platform="winphone" src="res/icon/windows-phone/icon-62-tile.png" role="background" />
    <!-- Windows Phone 8.1+ -->
    <icon platform="winphone" src="res/icon/windows-phone/square44x44logo.scale-100.png" width="44" height="44"/>
    <icon platform="winphone" src="res/icon/windows-phone/square44x44logo.scale-240.png" width="106" height="106"/>
    <icon platform="winphone" src="res/icon/windows-phone/square150x150logo.scale-100.png" width="150" height="150"/>
    <icon platform="winphone" src="res/icon/windows-phone/square150x150logo.scale-240.png" width="360" height="360"/>
    <icon platform="winphone" src="res/icon/windows-phone/square71x71logo.scale-100.png" width="71" height="71"/>
    <icon platform="winphone" src="res/icon/windows-phone/square71x71logo.scale-240.png" width="170" height="170"/>
    <!-- Launch images / splash screens -->
    <splash platform="android" qualifier="port-ldpi" src="res/screen/android/screen-ldpi-portrait.png" />
    <splash platform="android" qualifier="port-mdpi" src="res/screen/android/screen-mdpi-portrait.png" />
    <splash platform="android" qualifier="port-hdpi" src="res/screen/android/screen-hdpi-portrait.png" />
    <splash platform="android" qualifier="port-xhdpi" src="res/screen/android/screen-xhdpi-portrait.png" />
    <splash platform="android" qualifier="port-xhdpi" src="res/screen/android/screen-xhdpi-n7-portrait.png" />
    <splash platform="android" qualifier="port-xxhdpi" src="res/screen/android/screen-xxhdpi-portrait.png" />
    <splash platform="android" qualifier="port-xxhdpi" src="res/screen/android/screen-xxhdpi-n7-portrait.png" />
    <splash platform="android" qualifier="land-xxhdpi" src="res/screen/android/screen-xxhdpi-n7-landscape.png" width="1920" height="1200" />
    <splash platform="android" qualifier="land-xxhdpi" src="res/screen/android/screen-xxhdpi-landscape.png" width="1920" height="1080" />
    <splash platform="android" qualifier="land-xhdpi" src="res/screen/android/screen-xhdpi-n7-landscape.png" width="1280" height="800" />
    <splash platform="android" qualifier="land-xhdpi" src="res/screen/android/screen-xhdpi-landscape.png" width="1280" height="720" />
    <splash platform="android" qualifier="land-hdpi" src="res/screen/android/screen-hdpi-landscape.png" width ="800" height="480" />
    <splash platform="android" qualifier="land-mdpi" src="res/screen/android/screen-mdpi-landscape.png" width="480" height="320" />
    <splash platform="android" qualifier="land-ldpi" src="res/screen/android/screen-ldpi-landscape.png" width="320" height="200" />
    <!-- iPhone and iPod Touch -->
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait.png" width="320" height="480" />
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-2x.png" width="640" height="960" />
    <!-- iPhone 5 and iPod Touch (5th generation) -->
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-568h-2x.png" width="640" height="1136" />
    <!-- iPhone 6 -->
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-667h-2x.png" width="750" height="1334" />
    <splash platform="ios" src="res/screen/ios/screen-iphone-portrait-736h-3x.png" width="1242" height="2208" />
    <!-- iPad -->
    <splash platform="ios" src="res/screen/ios/screen-ipad-portrait.png" width="768" height="1024" />
    <splash platform="ios" src="res/screen/ios/screen-ipad-landscape.png" width="1024" height="768" />
    <!-- Retina iPad -->
    <splash platform="ios" src="res/screen/ios/screen-ipad-portrait-2x.png" width="1536" height="2048" />
    <splash platform="ios" src="res/screen/ios/screen-ipad-landscape-2x.png" width="2048" height="1536" />
    <!-- Windows 8 -->
    <splash platform="winphone" src="res/screen/windows-phone/screen-portrait.jpg" />
    <!-- Windows 8.1 -->
    <splash platform="winphone" src ="res/screen/windows-phone/screen.scale-240.png" />
    <access origin="*" />
    <allow-navigation href="http://*/*" />
    <allow-navigation href="https://*/*" />
    <allow-navigation href="data:*" />
    <allow-intent href="http://*/*" />
    <allow-intent href="https://*/*" />
    <platform name="ios" />
    <platform name="android" />
    <feature name="http://api.phonegap.com/1.0/file" />
    <feature name="http://api.phonegap.com/1.0/network" />
    <plugin name="cordova-plugin-console" source="npm" />
    <plugin name="cordova-plugin-device" source="npm" />
    <plugin name="cordova-plugin-device-motion" source="npm" />
    <plugin name="cordova-plugin-device-orientation" source="npm" />
    <plugin name="cordova-plugin-file" source="npm" />
    <plugin name="cordova-plugin-network-information" source="npm" />
    <plugin name="cordova-plugin-splashscreen" source="npm" />

    <plugin name="cordova-plugin-spinnerdialog" source="npm" />
    <plugin name="cordova-plugin-whitelist" source="npm" />

    <plugin name="ionic-plugin-keyboard" source="npm" />
    <plugin name="com.peerio.cordova.plugin.privacyscreen" spec="1.0.2" source="npm" />
    <plugin name="cordova-plugin-blurred-snapshot" spec="0.1.3" source="npm" />
    <plugin name="cordova-privacy-screen-plugin-mra" spec="0.3.1" source="npm" />
    <plugin spec="https://github.com/lifeofcoding/cordova-blur-app-privacy-screen.git" source="npm" />
    <plugin spec="https://github.com/ti8m/DocumentHandler.git" source="git" />



    <plugin name="cordova-plugin-dialogs" source="npm" />
    <plugin name="cordova-plugin-file-transfer" source="npm" version="1.5.1" />
    <plugin name="cordova-plugin-datepicker" source="npm" />
    <plugin name="cordova-plugin-file-opener2-base64" source="npm" />
    <plugin name="cordova-plugin-image-picker" source="npm" />
    <plugin name="cordova-plugin-native-transitions" source="npm" />
    <plugin name="de.appplant.cordova.plugin.printer" source="npm" />
    <plugin name="pushwoosh-pgb-plugin" source="npm" />

    <gap:config-file platform="ios" parent="UIBackgroundModes" overwrite="true">
    <array>
    <string>location</string>
    </array>
    </gap:config-file>


    <gap:config-file platform="ios" parent="NSLocationAlwaysUsageDescription">
    <string>This app uses location services for use with push notifications.</string>
    </gap:config-file>

    <plugin name="cordova-plugin-blurred-snapshot" source="npm" />
    <plugin name="cordova-privacy-screen-plugin-mra" source="npm" />
    <plugin name="com.peerio.cordova.plugin.privacyscreen" source="npm" />
    <plugin name="cordova-plugin-statusbar" source="npm" />
    <plugin name="cordova-plugin-x-toast" source="npm" />
    <plugin name="phonegap-plugin-push" source="npm" />
    <plugin spec="https://github.com/ti8m/DocumentHandler" source="git" />

    <plugin name="cordova-open" source="npm" />
    <plugin name="cordova-plugin-inappbrowser" source="npm" />
    </widget>
    and this the log file for IOS

    Build Date: 2017-11-12 23:59:46 -0800
    --------------------------------------------------------------------------------
    PLUGIN OUTPUT
    --------------------------------------------------------------------------------
    Fetching plugin "cordova-plugin-console" via npm
    Installing "cordova-plugin-console" at "1.1.0" for ios
    Fetching plugin "cordova-plugin-device" via npm
    Installing "cordova-plugin-device" at "1.1.7" for ios
    Fetching plugin "cordova-plugin-device-motion" via npm
    Installing "cordova-plugin-device-motion" at "2.0.0" for ios

    [DEPRECATED] - cordova-plugin-device-motion
    With the W3C Device Motion and Orientation API now being supported on iOS, Android and Windows devices, this plugin is not needed any more. Read more about the API at https://www.w3.org/TR/2016/CR-orient...vent-20160818/
    Fetching plugin "cordova-plugin-device-orientation" via npm
    Installing "cordova-plugin-device-orientation" at "2.0.0" for ios

    [DEPRECATED] - cordova-plugin-device-orientation
    With the W3C Device Motion and Orientation API now being supported on iOS, Android and Windows devices, this plugin is not needed any more. Read more about the API at https://www.w3.org/TR/2016/CR-orient...vent-20160818/
    Fetching plugin "cordova-plugin-file" via npm
    Installing "cordova-plugin-file" at "5.0.0" for ios
    Fetching plugin "cordova-plugin-network-information" via npm
    Installing "cordova-plugin-network-information" at "1.3.4" for ios
    Fetching plugin "cordova-plugin-splashscreen" via npm
    Installing "cordova-plugin-splashscreen" at "4.1.0" for ios
    Fetching plugin "cordova-plugin-spinnerdialog" via npm
    Installing "cordova-plugin-spinnerdialog" at "1.3.2" for ios
    Fetching plugin "cordova-plugin-whitelist" via npm
    Installing "cordova-plugin-whitelist" at "1.3.3" for ios
    Fetching plugin "ionic-plugin-keyboard" via npm
    Installing "ionic-plugin-keyboard" at "2.2.1" for ios
    Fetching plugin "com.peerio.cordova.plugin.privacyscreen@1.0.2" via npm
    Installing "com.peerio.cordova.plugin.privacyscreen" at "1.0.0" for ios
    Fetching plugin "cordova-plugin-blurred-snapshot@0.1.3" via npm
    Installing "cordova-plugin-blurred-snapshot" at "0.1.3" for ios
    Fetching plugin "cordova-privacy-screen-plugin-mra@0.3.1" via npm
    Installing "cordova-privacy-screen-plugin-mra" at "0.3.1" for ios
    Fetching plugin "https://github.com/lifeofcoding/cordova-blur-app-privacy-screen.git" via git clone
    Using shallow clone
    Repository "https://github.com/lifeofcoding/cordova-blur-app-privacy-screen.git" checked out to git ref "master" at "e9a6974".
    Installing "cordova-blur-app-privacy-screen" at "0.0.1" for ios
    Fetching plugin "https://github.com/ti8m/DocumentHandler.git" via git clone
    Using shallow clone
    Repository "https://github.com/ti8m/DocumentHandler.git" checked out to git ref "master" at "f501154".
    Installing "ch.ti8m.documenthandler" at "0.2.2" for ios
    Fetching plugin "cordova-plugin-dialogs" via npm
    Installing "cordova-plugin-dialogs" at "1.3.4" for ios
    "plugman install --platform ios --project /project --plugin cordova-plugin-file-transfer@1.5.1": Fetching plugin "cordova-plugin-file-transfer@1.5.1" via npm
    Installing "cordova-plugin-file-transfer" at "1.5.1" for ios
    Failed to install 'cordova-plugin-file-transfer': Error
    at /usr/local/lib/node_modules/pgb-plugman/node_modules/pgb-cordova-lib/src/plugman/install.js:581:33
    at _fulfilled (/usr/local/lib/node_modules/pgb-plugman/node_modules/q/q.js:787:54)
    at self.promiseDispatch.done (/usr/local/lib/node_modules/pgb-plugman/node_modules/q/q.js:816:30)
    at Promise.promise.promiseDispatch (/usr/local/lib/node_modules/pgb-plugman/node_modules/q/q.js:749:13)
    at /usr/local/lib/node_modules/pgb-plugman/node_modules/q/q.js:509:49
    at flush (/usr/local/lib/node_modules/pgb-plugman/node_modules/q/q.js:108:17)
    at _combinedTickCallback (internal/process/next_tick.js:95:7)
    at process._tickCallback (internal/process/next_tick.js:161:9)
    Version of installed plugin: "cordova-plugin-file@5.0.0" does not satisfy dependency plugin requirement "cordova-plugin-file@^4.0.0". Try --force to use installed plugin as dependency.

  4. #4
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Please help me with this.I`ve stuck with this for days. :'(

    Thank you in advance

  5. #5
    Member
    Real Name
    Arska Helm
    Join Date
    Jan 2015
    Posts
    19

    Default Re: Phonegap Build error

    HI, I would try either set the file-transfer plugin to version 1.7.0 ( now 1.5.1 fixed ) OR downgrade the file plugin to 4.3.3

    Yours Ari

  6. #6
    Member
    Real Name
    Jeff Grannis
    Join Date
    Apr 2016
    Location
    New Iberia, LA
    Posts
    90

    Default Re: Phonegap Build error

    I'm having similar problems although I'm using CLI 7.0.1 (cordova-android: 6.2.3). The PhoneGap Build logs say this for multiple plug-ins:
    Anyone know how to tell PhoneGap Build to use cordova-android: 6.3.0 (I don't see it in config.xml)

    Plugin doesn't support this project's cordova-android version. cordova-android: 6.2.3, failed version requirement: >=6.3.0
    Skipping 'cordova-plugin-geolocation' for android
    Fetching plugin "cordova-plugin-network-information" via npm
    Installing "cordova-plugin-network-information" at "1.3.4" for android
    Fetching plugin "cordova-plugin-dialogs" via npm
    Installing "cordova-plugin-dialogs" at "1.3.4" for android
    Fetching plugin "cordova-plugin-splashscreen" via npm
    Installing "cordova-plugin-splashscreen" at "4.1.0" for android
    Fetching plugin "cordova-open" via npm
    Installing "cordova-open" at "1.0.12" for android
    Fetching plugin "cordova-plugin-file" via npm
    Installing "cordova-plugin-file" at "5.0.0" for android
    Plugin doesn't support this project's cordova-android version. cordova-android: 6.2.3, failed version requirement: >=6.3.0
    Skipping 'cordova-plugin-file' for android
    Fetching plugin "cordova-plugin-file-transfer" via npm
    Installing "cordova-plugin-file-transfer" at "1.7.0" for android
    Plugin dependency "cordova-plugin-file@5.0.0" already fetched, using that version.
    Installing "cordova-plugin-file" at "5.0.0" for android
    Plugin doesn't support this project's cordova-android version. cordova-android: 6.2.3, failed version requirement: >=6.3.0
    Skipping 'cordova-plugin-file' for android

  7. #7
    Member
    Real Name
    Arska Helm
    Join Date
    Jan 2015
    Posts
    19

    Default Re: Phonegap Build error

    HI,

    The CLI 7.0.1 won't help ( android version 6.2.3 ). The problem is in File and file transfer plugins. I got similar messages with CLI 6.5.0 and 6.3.0.

    I changed the file plugin to 4.3.3 AND file-tranfer to 1.5.1.

    File 5.0.0 plugin is only tree days old and it requires later version of than cli 7.0.1.

    Ari

  8. #8
    Member
    Real Name
    Jeff Grannis
    Join Date
    Apr 2016
    Location
    New Iberia, LA
    Posts
    90

    Default Re: Phonegap Build error

    I was building fine on Friday night with CLI 7.0.1. And then this morning, the PhoneGap Builds are failing because of multiple plug-ins.

    On the Adobe forum, it seems that others are having the same type of problem this morning also (logs saying they need cordova-android: 6.3.0):
    https://forums.adobe.com/thread/2410942

  9. #9
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    6,193

    Default Re: Phonegap Build error

    Looks like changes to the cordova-plugin-file plugin have messed things up. Need to look into this further, but for now, use the prior version of that plugin. Your config.xml line for that plugin should be...

    Code:
    <plugin name="cordova-plugin-file" source="npm" version="4.3.3" />
    4.3.3 is the version prior to 5.0.0... which was released on Nov. 6.

    With 4.3.3 in place, builds under 7.0.1 and prior are ok.

    On first look, it seems as if 5.0.0 doesn't like cordova-plugin-file-transfer 1.5.1. Versions after 1.5.1 had issues... so Alpha defaults to 1.5.1. Maybe those issues have been fixed... have to see.

  10. #10
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Good news is my android build is compiled when I change changed the file plugin to 4.3.3 AND file-tranfer to 1.5.1

    <plugin name="cordova-plugin-file" source="npm" version="4.3.3"/>
    <plugin name="cordova-plugin-file-transfer" source="npm" version="1.5.1" />

    Bad news is , my IOS build still fail..Geez..Totally lost now..Why?
    Last edited by fatiha@pacific-orient.com; 11-13-2017 at 10:12 PM. Reason: spelling error

  11. #11
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Quote Originally Posted by fatiha@pacific-orient.com View Post
    Good news is my android build is compiled when I change changed the file plugin to 4.3.3 AND file-tranfer to 1.5.1

    <plugin name="cordova-plugin-file" source="npm" version="4.3.3"/>
    <plugin name="cordova-plugin-file-transfer" source="npm" version="1.5.1" />

    Bad news is , my IOS build still fail..Geez..Totally lost now..Why?
    This is the last log of it
    3 warnings generated.

    Ld /Library/Developer/Xcode/DerivedData/POI2U-dzvdjwfkkcxlmdboedcsfhkdssmm/Build/Intermediates/ArchiveIntermediates/POI2U/IntermediateBuildFilesPath/POI2U.build/Release-iphoneos/POI2U.build/Objects-normal/armv7/POI2U normal armv7
    cd /project
    export IPHONEOS_DEPLOYMENT_TARGET=8.0
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -arch armv7 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS10.1.sdk -L/project/build -L/project/POI2U/Plugins/pushwoosh-cordova-plugin -F/project/build -filelist /Library/Developer/Xcode/DerivedData/POI2U-dzvdjwfkkcxlmdboedcsfhkdssmm/Build/Intermediates/ArchiveIntermediates/POI2U/IntermediateBuildFilesPath/POI2U.build/Release-iphoneos/POI2U.build/Objects-normal/armv7/POI2U.LinkFileList -Xlinker -rpath -Xlinker @executable_path/Frameworks -miphoneos-version-min=8.0 -dead_strip -Xlinker -object_path_lto -Xlinker /Library/Developer/Xcode/DerivedData/POI2U-dzvdjwfkkcxlmdboedcsfhkdssmm/Build/Intermediates/ArchiveIntermediates/POI2U/IntermediateBuildFilesPath/POI2U.build/Release-iphoneos/POI2U.build/Objects-normal/armv7/POI2U_lto.o -fobjc-arc -fobjc-link-runtime -ObjC /project/build/libCordova.a -lz -framework CoreMotion -framework CoreLocation -weak_framework SystemConfiguration -framework CoreTelephony -framework QuartzCore -framework Accelerate -framework QuickLook -weak_framework AudioToolbox /project/POI2U/Plugins/pushwoosh-cordova-plugin/Pushwoosh -framework Security -framework Storekit -lstdc++ -lz -framework Foundation -Xlinker -dependency_info -Xlinker /Library/Developer/Xcode/DerivedData/POI2U-dzvdjwfkkcxlmdboedcsfhkdssmm/Build/Intermediates/ArchiveIntermediates/POI2U/IntermediateBuildFilesPath/POI2U.build/Release-iphoneos/POI2U.build/Objects-normal/armv7/POI2U_dependency_info.dat -o /Library/Developer/Xcode/DerivedData/POI2U-dzvdjwfkkcxlmdboedcsfhkdssmm/Build/Intermediates/ArchiveIntermediates/POI2U/IntermediateBuildFilesPath/POI2U.build/Release-iphoneos/POI2U.build/Objects-normal/armv7/POI2U

    Ld /Library/Developer/Xcode/DerivedData/POI2U-dzvdjwfkkcxlmdboedcsfhkdssmm/Build/Intermediates/ArchiveIntermediates/POI2U/IntermediateBuildFilesPath/POI2U.build/Release-iphoneos/POI2U.build/Objects-normal/arm64/POI2U normal arm64
    cd /project
    export IPHONEOS_DEPLOYMENT_TARGET=8.0
    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -arch arm64 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS10.1.sdk -L/project/build -L/project/POI2U/Plugins/pushwoosh-cordova-plugin -F/project/build -filelist /Library/Developer/Xcode/DerivedData/POI2U-dzvdjwfkkcxlmdboedcsfhkdssmm/Build/Intermediates/ArchiveIntermediates/POI2U/IntermediateBuildFilesPath/POI2U.build/Release-iphoneos/POI2U.build/Objects-normal/arm64/POI2U.LinkFileList -Xlinker -rpath -Xlinker @executable_path/Frameworks -miphoneos-version-min=8.0 -dead_strip -Xlinker -object_path_lto -Xlinker /Library/Developer/Xcode/DerivedData/POI2U-dzvdjwfkkcxlmdboedcsfhkdssmm/Build/Intermediates/ArchiveIntermediates/POI2U/IntermediateBuildFilesPath/POI2U.build/Release-iphoneos/POI2U.build/Objects-normal/arm64/POI2U_lto.o -fobjc-arc -fobjc-link-runtime -ObjC /project/build/libCordova.a -lz -framework CoreMotion -framework CoreLocation -weak_framework SystemConfiguration -framework CoreTelephony -framework QuartzCore -framework Accelerate -framework QuickLook -weak_framework AudioToolbox /project/POI2U/Plugins/pushwoosh-cordova-plugin/Pushwoosh -framework Security -framework Storekit -lstdc++ -lz -framework Foundation -Xlinker -dependency_info -Xlinker /Library/Developer/Xcode/DerivedData/POI2U-dzvdjwfkkcxlmdboedcsfhkdssmm/Build/Intermediates/ArchiveIntermediates/POI2U/IntermediateBuildFilesPath/POI2U.build/Release-iphoneos/POI2U.build/Objects-normal/arm64/POI2U_dependency_info.dat -o /Library/Developer/Xcode/DerivedData/POI2U-dzvdjwfkkcxlmdboedcsfhkdssmm/Build/Intermediates/ArchiveIntermediates/POI2U/IntermediateBuildFilesPath/POI2U.build/Release-iphoneos/POI2U.build/Objects-normal/arm64/POI2U
    ld: framework not found FileProvider for architecture arm64
    clang: error: linker command failed with exit code 1 (use -v to see invocation)

    ** ARCHIVE FAILED **


    The following build commands failed:
    Ld /Library/Developer/Xcode/DerivedData/POI2U-dzvdjwfkkcxlmdboedcsfhkdssmm/Build/Intermediates/ArchiveIntermediates/POI2U/IntermediateBuildFilesPath/POI2U.build/Release-iphoneos/POI2U.build/Objects-normal/arm64/POI2U normal arm64
    (1 failure)
    Error code 65 for command: xcodebuild with args: -xcconfig,/private/project/cordova/build-release.xcconfig,-workspace,POI2U.xcworkspace,-scheme,POI2U,-configuration,Release,-destination,generic/platform=iOS,-archivePath,POI2U.xcarchive,archive,CONFIGURATION_BUILD_DIR=/private/project/build/device,SHARED_PRECOMPS_DIR=/private/project/build/sharedpch

  12. #12
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    6,193

    Default Re: Phonegap Build error

    The whole PhoneGap Build environment is in a state of flux/panic because of changes made to Cordova.

    Bob Moore is updating the Alpha PhoneGap Build Builder to now include a version for each plugin. If you can wait until tomorrow morning, hopefully a new pre-release will be out.

    With the pre-release in hand we can see what versions of plugins to use. This doesn't mean you'll need to use the pre-release... it just means that we'll know for certain which versions to set in existing config.xml files.

  13. #13
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Quote Originally Posted by Davidk View Post
    The whole PhoneGap Build environment is in a state of flux/panic because of changes made to Cordova.

    Bob Moore is updating the Alpha PhoneGap Build Builder to now include a version for each plugin. If you can wait until tomorrow morning, hopefully a new pre-release will be out.

    With the pre-release in hand we can see what versions of plugins to use. This doesn't mean you'll need to use the pre-release... it just means that we'll know for certain which versions to set in existing config.xml files.
    Glad to hear that..Will wait for it then.. But to fix this I still need to use the pre-release right? Or the official release will be out soon after that?

  14. #14
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    6,193

    Default Re: Phonegap Build error

    No... you don't need the pre-release. We'll use the pre-release to find out what the plugin releases need to be used for PhoneGap Build. Then you can manually add in those versions to the config.xml of your project.
    Last edited by Davidk; 11-14-2017 at 02:47 AM.

  15. #15
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Quote Originally Posted by Davidk View Post
    No... you don't need the pre-release. We'll use the pre-release to find out what the plugin releases need to be for PhoneGap Build. Then you can manually add in those versions to the config.xml of your project.
    okay then..i will wait for the update

  16. #16
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    6,193

    Default Re: Phonegap Build error

    It looks like these are the affected plugins. Bob Moore has added version numbers into today's pre-release build... but for any build prior to this, just add the version number into your config.xml file.
    The Alpha PhoneGap Build Builder - Manage My PhoneGap Plugins - may help as well, as this takes your entry instead of any automated entry.

    Before submitting to PhoneGap Build, check to make sure there are no duplicate plugin entries .

    Code:
    	<plugin name="cordova-plugin-file" source="npm" version="4.3.3" />
    	<plugin name="cordova-plugin-file-transfer" source="npm" version="1.5.1" />
    	<plugin name="cordova-plugin-camera" source="npm" version="2.4.1" />
    	<plugin name="cordova-plugin-media-capture" source="npm" version="1.4.3" />
    	<plugin name="cordova-plugin-device" source="npm" version="1.1.7" />
    	<plugin name="cordova-plugin-network-information" source="npm" version="1.3.4" />
    	<plugin name="cordova-plugin-dialogs" source="npm" version="1.3.4" />
    	<plugin name="cordova-plugin-splashscreen" source="npm" version="4.1.0" />
    	<plugin name="phonegap-plugin-barcodescanner" source="npm" version="6.0.5" />
    	<plugin name="cordova-plugin-statusbar" source="npm" version="2.3.0" />
    	<plugin name="cordova-plugin-x-toast" source="npm" version="2.6.0" />
    	<plugin name="cordova-plugin-whitelist" source="npm" version="1.3.3" />
    	<plugin name="cordova-plugin-battery-status" source="npm" version="1.2.5" />
    	<plugin name="cordova-plugin-console" source="npm" version="1.1.0" />
    	<plugin name="cordova-plugin-contacts" source="npm" version="2.3.1" />
    	<plugin name="cordova-plugin-device-motion" source="npm" version="2.0.0"/>
    	<plugin name="cordova-plugin-device-orientation" source="npm" version="2.0.0" />
    	<plugin name="cordova-plugin-geolocation" source="npm" version="2.4.2" />
    	<plugin name="cordova-plugin-globalization" source="npm" version="1.0.8" />
    	<plugin name="cordova-plugin-inappbrowser" source="npm" version="1.7.2" />
    	<plugin name="cordova-plugin-vibration" source="npm" version="2.1.6" />
    	<plugin name="ionic-plugin-keyboard" source="npm" version="2.2.1" />
    	<plugin name="onesignal-cordova-plugin" source="npm" version="2.2.2" />
    	<plugin name="pdf417-phonegap" source="npm" version="1.1.8" />	
    	<plugin name="cordova-plugin-media" source="npm" version="3.0.1" />
    	<plugin name="cordova-sqlite-ext" source="npm" version="0.9.1" />
            <plugin name="pushwoosh-pgb-plugin" source="npm" version="7.0.4"/>
    Last edited by Davidk; 11-15-2017 at 12:11 PM.

  17. #17
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Quote Originally Posted by Davidk View Post
    It looks like these are the affected plugins. Bob Moore has added version numbers into today's pre-release build... but for any build prior to this, just add the version number into your config.xml file.
    The Alpha PhoneGap Build Builder - Manage My PhoneGap Plugins - may help as well, as this takes your entry instead of any automated entry.

    Before submitting to PhoneGap Build, check to make sure there are no duplicate plugin entries .

    Code:
    	<plugin name="cordova-plugin-file" source="npm" version="4.3.3" />
    	<plugin name="cordova-plugin-file-transfer" source="npm" version="1.5.1" />
    	<plugin name="cordova-plugin-camera" source="npm" version="2.4.1" />
    	<plugin name="cordova-plugin-media-capture" source="npm" version="1.4.3" />
    	<plugin name="cordova-plugin-device" source="npm" version="1.1.7" />
    	<plugin name="cordova-plugin-network-information" source="npm" version="1.3.4" />
    	<plugin name="cordova-plugin-dialogs" source="npm" version="1.3.4" />
    	<plugin name="cordova-plugin-splashscreen" source="npm" version="4.1.0" />
    	<plugin name="phonegap-plugin-barcodescanner" source="npm" version="6.0.5" />
    	<plugin name="cordova-plugin-statusbar" source="npm" version="2.3.0" />
    	<plugin name="cordova-plugin-x-toast" source="npm" version="2.6.0" />
    	<plugin name="cordova-plugin-whitelist" source="npm" version="1.3.3" />
    	<plugin name="cordova-plugin-battery-status" source="npm" version="1.2.5" />
    	<plugin name="cordova-plugin-console" source="npm" version="1.1.0" />
    	<plugin name="cordova-plugin-contacts" source="npm" version="2.3.1" />
    	<plugin name="cordova-plugin-device-motion" source="npm" version="2.0.0"/>
    	<plugin name="cordova-plugin-device-orientation" source="npm" version="2.0.0" />
    	<plugin name="cordova-plugin-geolocation" source="npm" version="2.4.2" />
    	<plugin name="cordova-plugin-globalization" source="npm" version="1.0.8" />
    	<plugin name="cordova-plugin-inappbrowser" source="npm" version="1.7.2" />
    	<plugin name="cordova-plugin-vibration" source="npm" version="2.1.6" />
    	<plugin name="ionic-plugin-keyboard" source="npm" version="2.2.1" />
    	<plugin name="onesignal-cordova-plugin" source="npm" version="2.2.2" />
    	<plugin name="pdf417-phonegap" source="npm" version="1.1.8" />	
    	<plugin name="cordova-plugin-media" source="npm" version="3.0.1" />
    	<plugin name="cordova-sqlite-ext" source="npm" version="0.9.1" />
    and for pushwoosh i use

    <plugin name="pushwoosh-pgb-plugin" source="npm" version="7.0.6"/>

    now everything is compiled fine

    Thank You David!!!

  18. #18
    Member
    Real Name
    Daniel Binns
    Join Date
    Apr 2017
    Posts
    15

    Default Re: Phonegap Build error

    David,

    Thank you for this. I was in a real jam yesterday.

  19. #19
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    6,193

    Default Re: Phonegap Build error

    Before submitting to PhoneGap Build, check to make sure there are no duplicate plugin entries in the config.xml file.

    <plugin name="cordova-plugin-file" source="npm" version="4.3.3" />
    <plugin name="cordova-plugin-file-transfer" source="npm" version="1.5.1" />
    <plugin name="cordova-plugin-camera" source="npm" version="2.4.1" />
    <plugin name="cordova-plugin-media-capture" source="npm" version="1.4.3" />
    <plugin name="cordova-plugin-device" source="npm" version="1.1.7" />
    <plugin name="cordova-plugin-network-information" source="npm" version="1.3.4" />
    <plugin name="cordova-plugin-dialogs" source="npm" version="1.3.4" />
    <plugin name="cordova-plugin-splashscreen" source="npm" version="4.1.0" />
    <plugin name="phonegap-plugin-barcodescanner" source="npm" version="6.0.5" />
    <plugin name="cordova-plugin-statusbar" source="npm" version="2.3.0" />
    <plugin name="cordova-plugin-x-toast" source="npm" version="2.6.0" />
    <plugin name="cordova-plugin-whitelist" source="npm" version="1.3.3" />
    <plugin name="cordova-plugin-battery-status" source="npm" version="1.2.5" />
    <plugin name="cordova-plugin-console" source="npm" version="1.1.0" />
    <plugin name="cordova-plugin-contacts" source="npm" version="2.3.1" />
    <plugin name="cordova-plugin-device-motion" source="npm" version="2.0.0"/>
    <plugin name="cordova-plugin-device-orientation" source="npm" version="2.0.0" />
    <plugin name="cordova-plugin-geolocation" source="npm" version="2.4.2" />
    <plugin name="cordova-plugin-globalization" source="npm" version="1.0.8" />
    <plugin name="cordova-plugin-inappbrowser" source="npm" version="1.7.2" />
    <plugin name="cordova-plugin-vibration" source="npm" version="2.1.6" />
    <plugin name="ionic-plugin-keyboard" source="npm" version="2.2.1" />
    <plugin name="onesignal-cordova-plugin" source="npm" version="2.2.2" />
    <plugin name="pdf417-phonegap" source="npm" version="1.1.8" />
    <plugin name="cordova-plugin-media" source="npm" version="3.0.1" />
    <plugin name="cordova-sqlite-ext" source="npm" version="0.9.1" />
    <plugin name="pushwoosh-pgb-plugin" source="npm" version="7.0.4"/>
    <plugin name="cordova-plugin-image-picker" source="npm" version="1.1.1" />

  20. #20
    Member
    Real Name
    YoungLuq
    Join Date
    Nov 2017
    Posts
    2

    Default Re: Phonegap Build error

    Quote Originally Posted by jgrannis View Post
    I'm having similar problems although I'm using CLI 7.0.1 (cordova-android: 6.2.3). The PhoneGap Build logs say this for multiple plug-ins:
    Anyone know how to tell PhoneGap Build to use cordova-android: 6.3.0 (I don't see it in config.xml)

    Plugin doesn't support this project's cordova-android version. cordova-android: 6.2.3, failed version requirement: >=6.3.0
    Skipping 'cordova-plugin-geolocation' for android
    Fetching plugin "cordova-plugin-network-information" via npm
    Installing "cordova-plugin-network-information" at "1.3.4" for android
    Fetching plugin "cordova-plugin-dialogs" via npm
    Installing "cordova-plugin-dialogs" at "1.3.4" for android
    Fetching plugin "cordova-plugin-splashscreen" via npm
    Installing "cordova-plugin-splashscreen" at "4.1.0" for android
    Fetching plugin "cordova-open" via npm
    Installing "cordova-open" at "1.0.12" for android
    Fetching plugin "cordova-plugin-file" via npm
    Installing "cordova-plugin-file" at "5.0.0" for android
    Plugin doesn't support this project's cordova-android version. cordova-android: 6.2.3, failed version requirement: >=6.3.0
    Skipping 'cordova-plugin-file' for android
    Fetching plugin "cordova-plugin-file-transfer" via npm
    Installing "cordova-plugin-file-transfer" at "1.7.0" for android
    Plugin dependency "cordova-plugin-file@5.0.0" already fetched, using that version.
    Installing "cordova-plugin-file" at "5.0.0" for android
    Plugin doesn't support this project's cordova-android version. cordova-android: 6.2.3, failed version requirement: >=6.3.0
    Skipping 'cordova-plugin-file' for android
    i'm having a similar problem too, but i can't seem to find the build log, the one i quote here, can anyone tell me where to find the log file? thanks for the help

  21. #21
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Quote Originally Posted by notLuqman View Post
    i'm having a similar problem too, but i can't seem to find the build log, the one i quote here, can anyone tell me where to find the log file? thanks for the help
    BUILD LOG.PNG

    If you go in your app in phonegap build you would see something like above..just click the log to get the build log.

    To edit the version you must edit your config.xml before submitting to phonegap.

  22. #22
    Member
    Real Name
    Wale Lasaki
    Join Date
    Apr 2012
    Location
    Abeokuta
    Posts
    28

    Default Re: Phonegap Build error

    Quote Originally Posted by Davidk View Post
    The whole PhoneGap Build environment is in a state of flux/panic because of changes made to Cordova.

    Bob Moore is updating the Alpha PhoneGap Build Builder to now include a version for each plugin. If you can wait until tomorrow morning, hopefully a new pre-release will be out.

    With the pre-release in hand we can see what versions of plugins to use. This doesn't mean you'll need to use the pre-release... it just means that we'll know for certain which versions to set in existing config.xml files.
    Please what is this phoneGap and what is it use for ? can i be illuminated? thanks

  23. #23
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Quote Originally Posted by lascvent View Post
    Please what is this phoneGap and what is it use for ? can i be illuminated? thanks
    The PhoneGap Build Integration lets you Develop and Deploy fully-functional HTML5 applications to mobile devices, access device hardware and also submit to the native app stores.

    https://www.alphasoftware.com/blog/b...y-and-quickly/

  24. #24
    Member
    Real Name
    YoungLuq
    Join Date
    Nov 2017
    Posts
    2

    Default Re: Phonegap Build error

    Quote Originally Posted by fatiha@pacific-orient.com View Post
    BUILD LOG.PNG

    If you go in your app in phonegap build you would see something like above..just click the log to get the build log.

    To edit the version you must edit your config.xml before submitting to phonegap.
    hi Nurul, thanks for replying!
    im using phonegap build from alpha, by pressing "manage my phonegap build apps" i got this menu shown, i don't have anything similar like the photo you posted, what are you using to build the phonegap apps ?
    manage phonegap.JPG

  25. #25
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Quote Originally Posted by notLuqman View Post
    hi Nurul, thanks for replying!
    im using phonegap build from alpha, by pressing "manage my phonegap build apps" i got this menu shown, i don't have anything similar like the photo you posted, what are you using to build the phonegap apps ?
    manage phonegap.JPG
    Your welcome..
    You can try this link https://build.phonegap.com/apps ..access from the phonegap site itself to see the log.

  26. #26
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    6,193

    Default Re: Phonegap Build error

    In the Alpha PhoneGap Build Project Settings... instead of clicking "Save and Upload to PhoneGap Build"... click Save. In the subsequent PhoneGap Configuration dialog you'll see a link "Click here to view/edit the PhoneGap Build XML configuation file". Clicking this link will open the Config.xml file. Whatever plugins you're using, ensure the appropriate version is applied to each. If you're using a plugin that is not in the list above in this thread, report it here... we'll figure it out.

    The other way of handling this is by building your own list of plugins using the "Manage My PhoneGap Plugins". However, this only works with 3rd Party plugins. In this case you'd uncheck all the 3rd party plugins in the builder, and add all the 3rd party plugins you want to include in the Manager... with version numbers. If you're working with the pre-release Alpha has already taken care of many of the plugin versions... core plus some 3rd party. If you're not working with the pre-release, then you'll need to ensure the config.xml file includes the versions for any plugins you're using. Prior to the pre-release, the builder will double up on plugins if you add them manually and have them checked... so watch out for that. As well, if you have them checked and included them in the Manager, the plugin will be added twice... so once again, watch out for that.

  27. #27
    Member
    Real Name
    NURUL FATIHAH BINTI ISMAIL
    Join Date
    Jul 2017
    Location
    MALAYSIA
    Posts
    32

    Default Re: Phonegap Build error

    Quote Originally Posted by Davidk View Post
    In the Alpha PhoneGap Build Project Settings... instead of clicking "Save and Upload to PhoneGap Build"... click Save. In the subsequent PhoneGap Configuration dialog you'll see a link "Click here to view/edit the PhoneGap Build XML configuation file". Clicking this link will open the Config.xml file. Whatever plugins you're using, ensure the appropriate version is applied to each. If you're using a plugin that is not in the list above in this thread, report it here... we'll figure it out.

    The other way of handling this is by building your own list of plugins using the "Manage My PhoneGap Plugins". However, this only works with 3rd Party plugins. In this case you'd uncheck all the 3rd party plugins in the builder, and add all the 3rd party plugins you want to include in the Manager... with version numbers. If you're working with the pre-release Alpha has already taken care of many of the plugin versions... core plus some 3rd party. If you're not working with the pre-release, then you'll need to ensure the config.xml file includes the versions for any plugins you're using. Prior to the pre-release, the builder will double up on plugins if you add them manually and have them checked... so watch out for that. As well, if you have them checked and included them in the Manager, the plugin will be added twice... so once again, watch out for that.
    I prefer the first method.Its easier that way.and yes sometime it duplicate the plugin.So everytime before submitting the app to phonegap just check for duplicate first to be safe.

  28. #28
    "Certified" Alphaholic
    Real Name
    David Kates
    Join Date
    Apr 2008
    Location
    Unionville, ON
    Posts
    6,193

    Default Re: Phonegap Build error

    Quote Originally Posted by jgrannis View Post
    I'm having similar problems although I'm using CLI 7.0.1 (cordova-android: 6.2.3). The PhoneGap Build logs say this for multiple plug-ins:
    Anyone know how to tell PhoneGap Build to use cordova-android: 6.3.0 (I don't see it in config.xml)

    Plugin doesn't support this project's cordova-android version. cordova-android: 6.2.3, failed version requirement: >=6.3.0
    Skipping 'cordova-plugin-geolocation' for android
    Fetching plugin "cordova-plugin-network-information" via npm
    Installing "cordova-plugin-network-information" at "1.3.4" for android
    Fetching plugin "cordova-plugin-dialogs" via npm
    Installing "cordova-plugin-dialogs" at "1.3.4" for android
    Fetching plugin "cordova-plugin-splashscreen" via npm
    Installing "cordova-plugin-splashscreen" at "4.1.0" for android
    Fetching plugin "cordova-open" via npm
    Installing "cordova-open" at "1.0.12" for android
    Fetching plugin "cordova-plugin-file" via npm
    Installing "cordova-plugin-file" at "5.0.0" for android
    Plugin doesn't support this project's cordova-android version. cordova-android: 6.2.3, failed version requirement: >=6.3.0
    Skipping 'cordova-plugin-file' for android
    Fetching plugin "cordova-plugin-file-transfer" via npm
    Installing "cordova-plugin-file-transfer" at "1.7.0" for android
    Plugin dependency "cordova-plugin-file@5.0.0" already fetched, using that version.
    Installing "cordova-plugin-file" at "5.0.0" for android
    Plugin doesn't support this project's cordova-android version. cordova-android: 6.2.3, failed version requirement: >=6.3.0
    Skipping 'cordova-plugin-file' for android
    The version you're looking for doesn't work that way. PhoneGap Build now has available PhoneGap 7.0.1 which includes the Cordova build for each platform as follows:
    iOS : 4.4.0
    Android : 6.2.3
    Windows : 5.0.0

    You don't get Android 6.3.0 using PhoneGap Build... it's not there yet. So... you must use a specific version of the plugin which will be ok for Android 6.2.3.
    https://blog.phonegap.com/phonegap-7...s-89087fe465f5

    Clear as mud... n'es pas?
    Last edited by Davidk; 11-17-2017 at 02:12 AM.

Similar Threads

  1. PhoneGap Build no longer works in version 12.3 Build 2682
    By richardurban in forum Mobile & Browser Applications
    Replies: 3
    Last Post: 07-07-2017, 01:03 AM
  2. Phonegap build not available and gives error
    By swest in forum Mobile & Browser Applications
    Replies: 1
    Last Post: 05-16-2017, 01:23 PM
  3. Phonegap Build Error
    By glenschild in forum Mobile & Browser Applications
    Replies: 2
    Last Post: 11-23-2016, 01:38 PM
  4. PhoneGap Build - c0000005 Error
    By CarlMPearson in forum Mobile & Browser Applications
    Replies: 0
    Last Post: 01-31-2015, 04:13 PM
  5. Phonegap Build Error
    By lutherhuffman in forum Mobile & Browser Applications
    Replies: 3
    Last Post: 04-25-2014, 11:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •