Alpha DevCon 2018
Results 1 to 2 of 2

Thread: strange 403 error opening files in root sub-directories

  1. #1
    "Certified" Alphaholic
    Real Name
    Chris Tappan
    Join Date
    Jun 2009
    Location
    Knoxville, TN
    Posts
    1,254

    Default strange 403 error opening files in root sub-directories

    I have pdf files in my application limited to access by anyone logged in.

    I'm having (what I believe to be new) problems with security on some of the application root sub-directories. If there's a way to set security by sub-directory, I don't even know how to do it, but I can't even establish a reasoning in my test results. I'm getting the same results in Chrome and Edge.

    Code:
    https://www.mywebsite.com/Files/unfiled/2.pdf works
    
    https://www.mywebsite.com/Files/Unfiled/2.pdf 403 error
    
    https://www.mywebsite.com/Files/Training/2.pdf works
    
    https://www.mywebsite.com/Files/training/2.pdf works
    
    https://www.mywebsite.com/Files/unfiled/other.pdf 403 error
    
    https://www.mywebsite.com/Files/Unfiled/other.pdf 403 error
    
    https://www.mywebsite.com/Files/New/other.pdf works
    I re-published my security settings and restarted my application server before getting these test results.

    Can someone help?

  2. #2
    "Certified" Alphaholic
    Real Name
    Chris Tappan
    Join Date
    Jun 2009
    Location
    Knoxville, TN
    Posts
    1,254

    Default Re: strange 403 error opening files in root sub-directories

    Hi all. I've been trying to figure this out and considering workarounds, but I'm still at a loss on this. In fact, the error message is this:

    WebSecurity: The security settings for this application are missing or incomplete.

    I've republished the project, restarted the application... For the most part, in the tests it behaves like the folder "[root]/Files/Unfiled" is the only folder giving this error. I can change the name on the folder and create a new folder called "Unfiled" and it still doesn't work. If I have to, I can rework my code to use a folder other than "Unfiled", but I'm concerned because I don't understand what's causing this issue.

    Help please?

Similar Threads

  1. Location of data files and directories
    By mexicomike in forum General Questions
    Replies: 5
    Last Post: 10-08-2011, 12:05 AM
  2. Windows 7 - Display of Files in Root Directory
    By Tom Cone Jr in forum General Questions
    Replies: 2
    Last Post: 08-21-2011, 06:57 AM
  3. Uploading files to directories other than c:\a5webroot
    By miket48 in forum Application Server Version 9 - Web/Browser Applications
    Replies: 12
    Last Post: 07-06-2009, 03:37 PM
  4. Upload files to a web sub-root directory?
    By ddiener in forum Application Server Version 9 - Web/Browser Applications
    Replies: 1
    Last Post: 09-29-2008, 02:53 AM
  5. Directories and moving files/applications
    By BDennis in forum Alpha Five Version 4
    Replies: 8
    Last Post: 01-27-2002, 01:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •