Using the Shortcut Genie
/documentation/pages/Guides/Desktop/Design/View/Database/Using the Shortcut Genie.xml
The Create Shortcut Genie creates a shortcut to load Alpha Anywhere and start a particular database. You can place the shortcut on the Start menu, in a particular group, or on the desktop. The Create Shortcut Genie lets you specify your own splash screen, title, and icon for the Alpha Anywhere program window, and also to specify special flags, such as whether the Alpha Anywhere window should be opened minimized or maximized and whether the user should be able to resize the main Alpha Anywhere window. To open the Create Shortcut Genie, select Tools > Create Shortcut.
Using the Xbasic Explorer to View Object Properties
/documentation/pages/Guides/Xbasic/Using the Xbasic Explorer to View Object Properties.xml
To determine the list of properties associated with an object, use the Xbasic Explorer. To display the Xbasic Explorer, select View > Code editor from the Control Panel menu. For example, if you have a form called Customer, navigate in the Xbasic Explorer to Objects > Windows > Customer > Properties to see a list of the properties associated with the form (as shown below):
Using the Button Genie
/documentation/pages/Guides/Desktop/Design/View/Layout Control/Using the Button Genie.xml
The Button Genie lets you easily create buttons that perform single or multiple steps. For example, you can use the Action Scripting Editor to create a custom script that executes the following actions when a user clicks a button:
Using the Spell Check
/documentation/pages/Guides/Desktop/Design/View/Database/Using the Spell Check.xml
The Alpha Anywhere Spell Check lets you check the current record, the current selection of records, or the current field. To start the Spell Check :
Report Help Pages
/documentation/pages/Index/Report Help Pages.xml
Pages relating to reports.
Using Xdialog to Filter a Report
/documentation/pages/Guides/Desktop/Xdialog/Using Xdialog to Filter a Report.xml
The following example shows the use of a multi-select list box with embedded check boxes with the AlphaSports sample database. It allows the operator to select multiple values from the BILL_CITY field, then uses this information to filter the fields that will appear on a report. The Xdialog form looks like this.
Report Structure
/documentation/pages/Guides/Report/Report Structure/index.xml
A Report is divided into several sections with headers and footers. These sections are the Report, Detail, and Groups sections.
Using the AppLauncher Component
/documentation/pages/Guides/Mobile and Web Components/AppLauncher/AppLauncher Component.xml
The AppLauncher component is designed to address the following problem: You have designed an application that is accessed through some URL.
Using the Audit Trail Feature
/documentation/pages/Guides/Desktop/Design/Data/DBF/Using the Audit Trail Feature.xml
Alpha Anywhere writes out an ASCII file which is an audit trail of all changes made to a record. The audit trail shows the date and time of the change, the original value in the field, and the new value in the field. To turn on the audit trail feature, you put the command: Addin.run("audit_trail") in the record's CanSaveRecord event. Also, if you want to keep track of deleted records, put Addin.run("audit_trail_deleteRecord") in the record's CanDeleteRecord event.
Using the Function Finder
/documentation/pages/Guides/Desktop/Design/Api/Using the Function Finder.xml
The Function Finder lets you type in a search string to find the right function for the task at hand. It also give you quick access to your most frequently used functions. You can access the Function Finder by selecting Interactive Window > Script or Code Editor > Code > Insert Function.