Get a Jumpstart with our Sample Apps
Results 1 to 3 of 3

Thread: Problems getting UDF recognised on the web server

  1. #1
    Member
    Real Name
    Malcolm Harison
    Join Date
    May 2012
    Location
    Whakatane, New Zealand
    Posts
    157

    Default Problems getting UDF recognised on the web server

    I am trying to filter drop down boxes (ddb) by specifying a variable in the ddb dialogue box (vListSchools), setting up a function that returns a CRLF list of both the 'name to display' and 'ID to store' and giving the variable some meaning with an 'OnGridInitialize' statement (ie e.rtc.vListSchools=ListSchools()). This works just as it should when I publish to Alpha5's local server - ie the lists display correctly, the ID's are stored in the correct field and the changes can be saved and retrieved.

    The problem comes when I publish it to the web server.

    I thought it must have something to do with the aex files not being managed correctly. So these are the checks I've done so far: (I'm using V11);
    1. recorded the aex filename (dbase name with aex extension as recommended) in the grid properties of each of the two relevant grids
    2. right clicked in the Control Panel Code Editor and compiled the functions into an aex file - confirmed
    3. Checked the Project Properties aex file section - the correct filename is recorded
    4. Ensured that all components that reference aex files are listed in the Project Properties aex dialogue box -they are
    5. When publishing, I've checked 'compile functions into an aex file,'
    6. Published the programme files (and aex files)
    7. Checked to make sure that the .aex file is on the server, in the same (relative) place as on my computer and that is was recently written to (its only 2kb with 3 functions, ok?)
    8. Exported the functions in the Code Editor to a txt file to check that they're all corerctly recorded - all three are listed as I expect them to be
    9. I've also copied the aex file on my desktop and pasted it into the server (as a separate exercise) to make sure it was getting there
    10. Tried the above exercise with a fresh, new grid - and using only one ddb and variable/function combo
    11. Published an A5w page with ?ListSchools - it returned correctly on the local server - but returned only one SchoolID number on the web server
    12. Published another A5w page with another of the functions - it returned correctly on the local server, but failed to display at all on the web server (website cannot display the page...)
    13. Ensured that the data files on the server are exactly the same as those on my desktop - by making a change to data on the web server, copying the file (mdb) onto my desktop and confirming that the changes were actually made - and repeating the process back the other way.
    14. Double checking all : , " ( and ) - although this shouldn't have been necessary because the local server would have thrown up any errors I hope
    15. Tried the ddb with 'add to the list' and 'do nothing.'
    16. Re-inserted each grid component onto the TabbedUI each time I made a change

    Although I have handled all three of my examples exactly the same way - the web server currently reports the following errors in the two separate grids:
    'Error executing OnGridInitialize event handler: Could not execute lookup query. Reported error: Table not found,' and
    'Error executing OnGridInitialize event handler: command: e.rtc.vListRTLB=ListRTLB() Function: 'ListRTLB' was not recognized.'

    I've also watched V10 Video 40 with respect to managing aex files, and TT vid 59, copied the instructions and followed them meticulously.

    At one point before this story began I renamed one of the tables referred to in one fo the UDF's for an unrelated reason. I checked every part of the grid and ensured that there was no reference to it (in response to the 'table not found' error). Just to make sure, I re-compiled the grid completely, deleted the original and renamed the new one the same as the old one.

    Just to make completely sure - I then deleted everything on the web server and re-published it all - data files included. (luckily I am still a few days away from going live!).

    The whole process still works fine on the local server - but there's no change to the web server display.

    I am now (at last) devoid of any ideas as to where to find what I've overlooked. Thank goodness the whole process still works fine on the local server or I would certainly have given up by now. If you've hung in to this point, you may just have new inspiration for me ...

  2. #2
    Moderator
    Real Name
    Steve Workings
    Join Date
    Apr 2000
    Location
    The Dreaded Chair
    Posts
    5,507

    Default Re: Problems getting UDF recognised on the web server

    1. Make sure your .AEX is in the webroot - you don't specify.
    2. Don't reference/assign the AEX in the grid component.
    3. 2-3k for a couple functions is probably fine.
    4. Try clearing your server's AEX cache - right click on the A5 web server icon on the server's task tray and "Clear AEX cache"
    5. Make sure your server version and desktop version are the same (probably not the cause for this but worth mentioning)
    -Steve


  3. #3
    Member
    Real Name
    Malcolm Harison
    Join Date
    May 2012
    Location
    Whakatane, New Zealand
    Posts
    157

    Default Re: Problems getting UDF recognised on the web server

    Clearing the cache did it! Fantastic. Thanks again Steve.

Similar Threads

  1. How do you open Sub- UDF from parent UDF
    By johnkoh in forum Alpha Five Version 9 - Desktop Applications
    Replies: 41
    Last Post: 03-01-2012, 03:53 PM
  2. Problems publishing app to web server
    By envisionsolutions in forum Application Server Version 10 - Web/Browser Applications
    Replies: 3
    Last Post: 05-07-2010, 07:11 AM
  3. Update Version not being recognised
    By howardcox in forum Alpha Five Version 8
    Replies: 2
    Last Post: 09-20-2007, 04:44 PM
  4. Session variables not being recognised after publish to web server
    By den1s in forum Application Server Version 8
    Replies: 6
    Last Post: 08-16-2007, 12:24 PM
  5. Function is not recognised error
    By Mattyau in forum Alpha Five Version 5
    Replies: 2
    Last Post: 11-30-2004, 10:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •